Supra eKey

SUPRA eKey Software Upgrade Requires Apple iOS 12+ or Android OS 8+

On December 31st, older Supra eKEY apps will no longer function. To ensure you maintain access to Supra Lockboxes, please update to the most recent version of the eKEY app as soon as possible. The latest version of the eKEY app requires your device to use one of the following operating systems: Apple iOS 12 or later. (Not sure which version you have? See Apple’s guide.) Android OS 8 or later. (Not sure which version you have? See Google’s guide.) Although most devices in use today can run the latest version of the eKEY app, there may be some older devices that may not be able to update to this version. This means that a very small percentage of people may need to upgrade to a newer device. If you know you use an older device, or are not sure, please check out Supra’s guide to device and software requirements....Continue reading

Scroll to top